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Using Workbench as a Sedona Tool 
For those who have access to Niagara Workbench, this programming tool for Niagara Framework works well 
as a Sedona Tool when programming devices built on the Sedona Framework.  Niagara Workbench is available 
from Tridium or from a Tridium OEM.  It can be called by several different names such as Workplace or 
ProBuilder but we will use the generic term Workbench to mean Niagara Workbench with Sedona installed.  
Workbench does not come from the factory with Sedona installed but it can be easily updated for Sedona on 
Workbench versions 3.7.x or 3.8.x.  The discussion that follows assumes a basic understanding of Niagara 
Workbench by the user.  Keep in mind that Niagara Workbench is a complex tool because it was originally 
developed for Niagara Framework use.  There are many features in the program that are not applicable to 
Sedona Framework so they will not be discussed. 

Installing Sedona into Workbench 

After starting Workbench, click on File > Open 
and see if you have an option called Open 
Device.  If it is there, Sedona is installed and 
you can skip this section and go to the section 
on installing component bundles.  If you do not 
see Open Device you need to install Sedona 
Framework into Workbench.   

Go to the Contemporary Controls’ web site and 
click on Support > Product Support Materials > 
Sedona and download the Sedona Framework 
TXS Bundle for either Workbench 3.7 or 3.8 to match the Workbench version you have.  The Workbench 
version is clearly marked on its welcome screen.  Download the bundle and put it on your desktop for 
convenience but leave it zipped.  Go back to Workbench and click Tools>Sedona Installer and you will see the 
following screen.   Accept the default settings.  Click the file icon to browse for your file.   Click Next. 
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After you click Next you might receive a message about Module Downgrade.  Just ignore the message by 
clicking Yes.  Click Finish and Sedona will be installed. 

Installing the Component Bundle 

When you install Sedona in Workbench you will gain a sub folder called sedona within 
the Niagara directory.  It can typically be found in the Windows’ root directory at 
Niagara>Niagara 3.8.  If you click on sedona you will see four folders – kits, manifests, 
platforms and store.  The first three folders store information about the personality of 
Sedona devices while the fourth folder is where Sedona applications and Sedona device 
information is backed up.  When Sedona is installed on the Workbench tool, there is a set of Sedona release 
1.2 components that will populate the first three folders.  Components are organized in meaningful module 
groups and deployed as kits.  These component kits come from Tridium and are hardware independent in that 
they will run on any Sedona 1.2 device.  For example, And2 and Or2 are Boolean logic components which can 
be found in the Logic Kit from Tridium.  

 However, Contemporary Controls has developed component kits specific to the Sedona platforms it 
developed and these must also be installed.  These kits are designated by vendor, product name and module 
type such as CControls_BASC20_IO.  In addition, Contemporary Controls has developed hardware-
independent component kits that would be beneficial to the Sedona community and these should also be 
installed.  These types of kits are identified by vendor and module type such as CControls_Function.  
Collectively, these kits are provided in a component bundle and labelled with a product identifier and a bundle 
number.  As more components and kits are developed, they are added to the bundle and the revision number 
of the bundle is incremented.  No components or kits are ever removed so that installing the latest bundle 
does not cause harm.  For the BAScontrol series, the bundle would have a name such as 
Component_Bundle_BASC_1.0.19.  The latest bundle can be found on the same web page were the TXS 
bundles were found.  Like the TXS bundles, the Component bundles are zip files that should be left unzipped 
for installation.  Use the same method for installing the component bundles as was done with the TXS bundles.  
The Sedona Installer in Workbench will then add those kits, manifests and platforms in the appropriate folders 
if they do not exist already.  Once this is done you can access a Sedona device. 

Accessing a Sedona Device 

For the Sedona device we will use a controller in the 
BAScontrol series (BASC).  Like other Sedona devices, 
the BASC is IP-based so we need Workbench to be 
on the same sub-net as the BASC.  In this example 
we have the BASC addressed at 10.0.0.249.  Using a 
web browser we can try to access this IP address.  If 
we obtain an Authentication Request from this 
controller, we are assured we are on the right sub-
net.  We can enter credentials for this controller to 
view the main web page or we could just close our 
web browser and bring up Workbench. 

At the Workbench home screen, click File > Open > Open Device and while accepting the default settings 
enter the IP address of the controller and then click OK.   If you cannot find Open Device, Sedona is not 
installed.  
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Next you will be prompted for credentials.  The default credentials are 
admin/admin.  You can click on Remember these credentials if you 
which.  Click Ok. 

 

If you are successful you will see a reference in the main window for 
Sedona Tools and App.  Click on App. 

 

The application property sheet should appear.  The default Device Name 
would be the product name.  This can be changed.  The default App Name 
is simply Default app and this can be 
changed as well.  The Scan Period 
indicates how often Sedona logic is solved.  
Although Sedona can execute wire sheets 
in less than 100 ms, time must be left for 
the controller to do other background 
tasks including updating web pages.  It is 
best to leave this setting at 200 ms.  Leave 
the other settings at their default value. 

 

 

There are two ways to reach the wire sheet.  The first is just to click on the 
sheet folder in the App property sheet.  The second is to go to the Navigation 
pane and expand the navigation tree for the controller being accessed.  By 
clicking on sheet, you should be able to see the main wire sheet although the 
default wire sheet is blank.   

 

 

Now that you have opened up the wire sheet you should see the Sedona Palette 
just below the Navigation pane.  If it is not there, go to the Side Bars icon just 
below the word Bookmarks and click on the drop-down menu.  Select Sedona 
Palette and it will appear.  
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Accessing the Sedona Palette 

Once the Sedona Palette is viewable you can see all 
the component kits that reside on the connected 
Sedona device.  Each kit is represented by the jar 
icon.  Click on the drop-down menu to see all the kits.  
The Tridium 1.2 release kits carry no vendor name 
while custom kits do such as the Contemporary 
Controls’ IO, Web and Function kits.  If they also carry 
a product designation, these kits are hardware 
dependent and not portable to another Sedona 
device. 

 

 

 

 

Using the drop-down, select the 
CControls_BASC20_IO kit.  In the case of the 
BAScontro20 there are 49 components to choose 
from – 20 real points, 24 virtual points, a scan timer 
and 4 retentive universal counters.  All are intended 
for one time use and only those dragged onto the 
wire sheet will become part of the logic of the 
controller.   
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Using the Sedona Tools within Workbench  

If you go into the navigation pane and expand the IP address of the Sedona 
device you can access the three Sedona Tools.  The three Sedona tools along 
with what service they can provide are listed on the right.  You will notice 
that at the header is the name of the Sedona 
application running on the attached controller.  
This way you can confirm that the controller is 
executing the application that is of interest.  

 Directly below the list of tools is a list of kits 
that are installed on the controller.  This 
information comes from the Schema read from the 
installed app.sab file on the controller.  Notice that at the 
top of the list is platform information that comes from 
the controller.  A checksum accompanies each kit.  Having 
a kit does not necessarily means that components in the 
kit are being used.  It just means that the controller can 
support all of the components from that kit. 

Using the Application Manager 

By clicking on Application Manager you can either save or 
restore the application which includes all the wire sheet 
information.  A Get captures the app.sab from the 
controller, converts it to an app.sax, and stores it where 
you want it while offering you a suggested file name and 
location.  If you want you can append the last quad of the 
IP address of the controller to the file name if you have 
several controllers running the same application.  This 
way you can easily locate the controller you just backed 
up.  Accept the default checkbox for saving the kit 
checksums, click Next, then Finish and then Close and you will have a copy of your application on your 
computer that is running Workbench.  Saving the app.sab file is quick and easy but it only saves the app.sab 
and nothing about web page configurations and BACnet information. 
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To restore an app.sab file onto the controller you will need to do a Put.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You will be presented with a choice of files.  You can click on the Modified column to arrange the files by date 
to help you search for the one you want.  Once you highlight it, click Next at the bottom of the screen. 

You will be presented with a list of kits 
along with the ability to make kit 
changes.  The kits installed in the 
controller will have either a check 
mark or an icon indicating that it is 
being used in the application.  The 
installed version is then listed.  The 
column called Latest identifies the 
version number available in the 
Component Bundle that was installed 
in Workbench.  If a version difference 
is noted, then you have the option to 
Keep, Upgrade or Downgrade.  It is 
best to ignore these options and just 
click Next.   

If a kit is not found in Workbench, or a 
kit is present but with a different 
checksum, it will be necessary to 
upgrade you Component Bundle.  
Contemporary Controls only adds kits 
to Component Bundles and does not 
remove old kits.  Therefore it is safe to 
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install the latest bundle.  Complete the operation by clicking Next and then Finish.  You can observe the 
progress of the restore operation on the subsequent screen. 

Once the restore is completed 
you will be prompted to Restart 
the Device.  Go ahead and do 
that.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You will notice that you will lose connection 
to the controller.  Just wait until the 
controller is finished restarting and then log 
into the controller again. 
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Using the Backup/Restore Tool 

The second tool is the Backup/Restore tool which should not be confused with Contemporary Controls’ 
Sedona Backup and Restore Utility.  The former only backs up applications while the latter backs up the 
complete Contemporary Controls’ controller project including BACnet configuration and web pages.  The main 
difference between the Backup/Restore tool and the Application Manager tool is that the kits.scode file is also 
saved during the backup process and is put back during the restore process.  Backing up the kits.scode file 
takes much more time. 

Clicking on the Backup/Restore option 
gains you a screen asking for 
selections.  Do not ask to have the 
Sedona VM backed up and it is usually 
not necessary to backup 
dependencies.  However, you should 
leave the box checked for backing up 
the app.sab and the kits.scode.  Notice 
that you will be saving everything in 
one zip file.  Change the name or 
append the controller number if you 
wish.  Also notice that you will not be 
generating an app.sax like you did 
when using the Application Manager.  
Click Next and then Finish to complete 
the process.  You can observe the 
backup process with the following 
screen.  Once the process is completed 
by announcing Finished, click Close. 

 

 

 

 

To do a restore, select the Restore 
option and you will be presented with a 
choice of files.  Select the one you want 
and click Next and Finish.  It is not 
necessary to restore dependencies. 

Once the process is complete you will 
be prompted to Restart the device.  Do 
so and then wait until the controller 
restarts before accessing it again with 
Workbench. 
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Using the Kit Manager 

The final Sedona tool in Workbench is the Kit Manager.  The Kit Manager allows you to generate a proper 
kits.scode file based upon the kits you select.  The Kit Manager firsts compares the kits that are installed on the 
controller with those available on Workbench.  If different versions of kits exist, then you are given the option 
to Keep, Upgrade or Downgrade that particular kit.  Once selections are made, the Kit Manager uses the 
app.sax version of the installed app.sab and generates a new kits.scode for use in the controller.  It is highly 
recommended to use the Kit Manager only at the direction of Contemporary Controls’ technical support.  
Consider this tool as only necessary for invoking advanced features of Sedona Framework. 

 


